NetSight
medium4.3Public exploit code

CVE-2026-44595

Yamcs vulnerable to unauthorized user enumeration via IAM API endpoints

Public exploit code

Working exploit or proof of concept code has been published for this vulnerability. Treat unpatched systems as at risk.

Impact

Yamcs is a mission control framework. Prior to 5.12.7, the IAM API endpoints listUsers, getUser, listGroups, and getGroup in yamcs-core did not enforce the required SystemPrivilege.ControlAccess check in yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java, so any authenticated user, even one with low or no privileges, could enumerate all user accounts in the system including their usernames, superuser status, and group memberships. This issue is fixed in versions 5.12.7 and 5.13.0.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.yamcs:yamcs-core< 5.12.75.12.7

Affected products

VendorProductAffected versions
SpaceapplicationsYamcs
before 5.12.7

Weakness classification

References