NetSight
medium6.1

CVE-2026-44613

Cross-Site Request Forgery (CSRF) vulnerability in Apache Zeppelin.

Impact

Cross-Site Request Forgery (CSRF) vulnerability in Apache Zeppelin. The default CORS configuration allowed cross-origin state-changing requests and accepted text/plain request bodies, allowing an attacker who lures an authenticated user to a                   malicious site to perform actions on the user's behalf through REST and WebSocket endpoints. This issue affects Apache Zeppelin versions 0.6.0 through 0.12.0. Users are recommended to upgrade to version 0.12.1, which fixes this issue.

Affected products

VendorProductAffected versions
ApacheZeppelin
from 0.6.0 before 0.12.1

Weakness classification

References