high8.2
CVE-2026-44728
@babel/plugin-transform-modules-systemjs generates arbitrary code when compiling malicious input
Impact
Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | @babel/plugin-transform-modules-systemjs | >= 7.12.0, <= 7.29.3 | 7.29.4 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Babel | Babel | from 7.12.0 before 7.29.4 Version 8.0.0 |