CVE-2026-44911
Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed…
Impact
Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.nifi:nifi-web-api | >= 1.15.0, < 2.10.0 | 2.10.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Nifi | from 1.15.0 before 2.10.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-qvj8-gwpm-4x49
- https://nvd.nist.gov/vuln/detail/CVE-2026-44911
- https://lists.apache.org/thread/wrj3t4k2bwd2cztyp078f5kj3722qfzy
- http://www.openwall.com/lists/oss-security/2026/06/20/4
- https://github.com/apache/nifi/commit/f30f877fb3e0e2a0db7850be8b6d586203860a45