high8.2
CVE-2026-44981
CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression
Impact
CrowdSec offers crowdsourced protection against malicious IPs. From 1.7.0 until 1.7.8, the LAPI router used gin-contrib/gzip with DefaultDecompressHandle globally in pkg/apiserver/controllers/controller.go, causing /v1/watchers and /v1/watchers/login to decompress unauthenticated gzip-compressed JSON request bodies without enforcing a maximum decompressed size and allowing excessive heap allocation that can make LAPI unreachable. This issue is fixed in version 1.7.8.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/crowdsecurity/crowdsec | >= 1.7.0, < 1.7.8 | 1.7.8 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-273h-gvwr-c3qj
- https://github.com/crowdsecurity/crowdsec/security/advisories/GHSA-273h-gvwr-c3qj
- https://github.com/crowdsecurity/crowdsec/releases/tag/v1.7.8
- https://github.com/crowdsecurity/crowdsec/commit/54a0dfe6c16b7687b0da6634e0b19ef0f5d9bb30
- https://github.com/crowdsecurity/crowdsec/commit/56d0d6915f7f25941dc5b4f484028646f6601a37