high8.6
CVE-2026-45077
Symfony is a PHP framework for web and console applications and a set of reusable PHP components.
Impact
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, the server:log listener (Symfony\Bridge\Monolog\Command\ServerLogCommand) binds to 0.0.0.0:9911 by default and processes each received frame with unserialize(base64_decode($message)) without authentication, integrity checks, or an allowed_classes allowlist, allowing any reachable host to submit attacker-chosen serialized PHP payloads that can crash the listener and may trigger object-injection gadget effects. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | symfony/monolog-bridge | < 5.4.52 | 5.4.52 |
| composer | symfony/symfony | < 5.4.52 | 5.4.52 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Sensiolabs | Symfony | before 5.4.52 from 6.0.0 before 6.4.40 from 7.0.0 before 7.4.12 from 8.0.0 before 8.0.12 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-m7v2-7gxm-vc2v
- https://github.com/symfony/symfony/security/advisories/GHSA-m7v2-7gxm-vc2v
- https://github.com/symfony/symfony/commit/0891b2f293896c488e26943dc034334364b77fc4
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/monolog-bridge/CVE-2026-45077.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2026-45077.yaml
- https://symfony.com/cve-2026-45077
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12