high7.5
CVE-2026-45133
Symfony is a PHP framework for web and console applications and a set of reusable PHP components.
Impact
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | symfony/yaml | < 5.4.52 | 5.4.52 |
| composer | symfony/symfony | < 5.4.52 | 5.4.52 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Sensiolabs | Symfony | before 5.4.52 from 6.0.0 before 6.4.40 from 7.0.0 before 7.4.12 from 8.0.0 before 8.0.12 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-c2p3-7m5p-cv8x
- https://github.com/symfony/symfony/security/advisories/GHSA-c2p3-7m5p-cv8x
- https://github.com/symfony/symfony/commit/914f427ed9630ddb3904dafba763e53d9f133fe3
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2026-45133.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/yaml/CVE-2026-45133.yaml
- https://symfony.com/cve-2026-45133
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12