medium5.3
CVE-2026-45205
Apache Commons Configuration: StackOverflowError for YAML input with cycles
Impact
Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.commons:commons-configuration2 | >= 2.2, < 2.15.0 | 2.15.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Commons Configuration | from 2.2 before 2.15.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-337m-mw94-2v6g
- https://nvd.nist.gov/vuln/detail/CVE-2026-45205
- https://github.com/apache/commons-configuration/pull/634
- https://lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk
- http://www.openwall.com/lists/oss-security/2026/05/14/5