NetSight
high7.3

CVE-2026-46588

Apache Camel-CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

Impact

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.camel:camel-couchdb>= 4.0.0, < 4.14.84.14.8

Affected products

VendorProductAffected versions
ApacheCamel
from 4.0.0 before 4.14.8
from 4.15.0 before 4.18.3
from 4.19.0 before 4.21.0

Weakness classification

References