NetSight
medium4.3

CVE-2026-46605

Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with pro…

Impact

Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.activemq:apache-activemq< 5.19.75.19.7

Affected products

VendorProductAffected versions
ApacheActivemq
before 5.19.7
from 6.0.0 before 6.2.6
ApacheActivemq Broker
before 5.19.7
from 6.0.0 before 6.2.6

Weakness classification

References