medium6.5
CVE-2026-46718
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.
Impact
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Users are recommended to upgrade to version 1.42, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.calcite:calcite-core | >= 1.5.0, < 1.42.0 | 1.42.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Calcite | from 1.5.0 before 1.42.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-c2rv-hwqm-wjpg
- https://nvd.nist.gov/vuln/detail/CVE-2026-46718
- https://lists.apache.org/thread/9s37svo343w5ck1ovh478lkzcqk4949v
- http://www.openwall.com/lists/oss-security/2026/06/01/7
- https://github.com/apache/calcite/commit/5855cfa14d8038e2a123ff6ce9722edce0e0cc25
- https://issues.apache.org/jira/browse/CALCITE-7532