high8.7
CVE-2026-47759
TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
Impact
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | tinymce | >= 6.0.0, < 7.9.3 | 7.9.3 |
| nuget | TinyMCE | >= 6.0.0, < 7.9.3 | 7.9.3 |
| composer | tinymce/tinymce | >= 6.0.0, < 7.9.3 | 7.9.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Tiny | Tinymce | before 5.11.1 from 6.0.0 before 7.9.3 from 8.0.0 before 8.5.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-q742-qvgc-gc2f
- https://github.com/tinymce/tinymce/security/advisories/GHSA-q742-qvgc-gc2f
- https://nvd.nist.gov/vuln/detail/CVE-2026-47759
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overview