high8.7
CVE-2026-47760
TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs
Impact
TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | tinymce | >= 6.8.0, < 7.1.0 | 7.1.0 |
| nuget | TinyMCE | >= 6.8.0, < 7.1.0 | 7.1.0 |
| composer | tinymce/tinymce | >= 6.8.0, < 7.1.0 | 7.1.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Tiny | Tinymce | from 6.8.0 before 7.1.0 |