high8.7
CVE-2026-47761
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
Impact
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | tinymce | >= 6.0.0, < 7.9.3 | 7.9.3 |
| nuget | TinyMCE | >= 6.0.0, < 7.9.3 | 7.9.3 |
| composer | tinymce/tinymce | >= 6.0.0, < 7.9.3 | 7.9.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Tiny | Tinymce | before 5.11.1 from 6.0.0 before 7.9.3 from 8.0.0 before 8.5.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-vg35-5wq7-3x7w
- https://github.com/tinymce/tinymce/security/advisories/GHSA-vg35-5wq7-3x7w
- https://nvd.nist.gov/vuln/detail/CVE-2026-47761
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overview