NetSight
high8.7

CVE-2026-47762

TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments

Impact

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Affected packages

EcosystemPackageAffectedFixed in
npmtinymce>= 6.0.0, < 7.9.37.9.3
nugetTinyMCE>= 6.0.0, < 7.9.37.9.3
composertinymce/tinymce>= 6.0.0, < 7.9.37.9.3

Affected products

VendorProductAffected versions
TinyTinymce
before 5.11.1
from 6.0.0 before 7.9.3
from 8.0.0 before 8.5.1

Weakness classification

References