critical9.1
CVE-2026-48746
vLLM is an inference and serving engine for large language models (LLMs).
Impact
vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authentication bypass of the OpenAI API AuthenticationMiddleware. It allows to use the API without providing the configured VLLM_API_KEY or --api-key. This vulnerability is fixed in 0.22.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | vllm | >= 0.3.0, < 0.22.0 | 0.22.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vllm | Vllm | from 0.3.0 before 0.22.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-94f4-hr76-p5j6
- https://github.com/vllm-project/vllm/security/advisories/GHSA-94f4-hr76-p5j6
- https://github.com/vllm-project/vllm/pull/43426
- https://x41-dsec.de/lab/advisories/x41-2026-002-starlette
- https://nvd.nist.gov/vuln/detail/CVE-2026-48746
- https://access.redhat.com/errata/RHSA-2026:30088
- https://access.redhat.com/errata/RHSA-2026:30089
- https://access.redhat.com/errata/RHSA-2026:36005
- https://access.redhat.com/errata/RHSA-2026:36006
- https://access.redhat.com/security/cve/CVE-2026-48746
- https://bugzilla.redhat.com/show_bug.cgi?id=2491581
- https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-226.yaml
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-48746.json
- https://access.redhat.com/errata/RHSA-2026:42132
- https://access.redhat.com/errata/RHSA-2026:42142
- https://access.redhat.com/errata/RHSA-2026:42644
- https://access.redhat.com/errata/RHSA-2026:43038
- https://access.redhat.com/errata/RHSA-2026:61629
- https://access.redhat.com/errata/RHSA-2026:61627