NetSight
high7.3

CVE-2026-49042

Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters

Impact

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.camel:camel-langchain4j-tools>= 4.8.0, < 4.18.34.18.3
mavenorg.apache.camel:camel-langchain4j-agent>= 4.8.0, < 4.18.34.18.3
mavenorg.apache.camel:camel-spring-ai-tools>= 4.8.0, < 4.18.34.18.3

Affected products

VendorProductAffected versions
ApacheCamel
from 4.8.0 before 4.18.3
from 4.19.0 before 4.21.0

Weakness classification

References