high8.8
CVE-2026-49157
Apache ActiveMQ has an Incorrect Default Permissions vulnerability
Impact
Incorrect Default Permissions vulnerability in Apache ActiveMQ. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.activemq:apache-activemq | < 5.19.7 | 5.19.7 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Activemq | before 5.19.7 from 6.0.0 before 6.2.6 |