NetSight
high7.3

CVE-2026-50015

pnpm Vulnerable to Arbitrary File Write/Delete via Malicious Patch File (Path Traversal)

Impact

pnpm is a package manager. Prior to 10.34.0 and 11.4.0, pnpm's patch application pipeline (@pnpm/patch-package) performs no path validation on file paths extracted from .patch files. An attacker who contributes a malicious patch file via a pull request can write attacker-controlled content to or delete arbitrary files on the filesystem during pnpm install, as the user running the install. The diff --git header paths containing ../../ sequences traverse out of the package directory, and the traversal is difficult to catch in code review because patch file diff headers are opaque to most reviewers. This vulnerability is fixed in 10.34.0 and 11.4.0.

Affected packages

EcosystemPackageAffectedFixed in
npmpnpm< 10.34.010.34.0

Affected products

VendorProductAffected versions
PnpmPnpm
before 10.34.0
from 11.0.0 before 11.4.0

Weakness classification

References