critical9.8
CVE-2026-50633
A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipu…
Impact
A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.cxf:cxf-integration-jca | >= 4.2.0, < 4.2.2 | 4.2.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Cxf | before 4.1.7 from 4.2.0 before 4.2.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-qp3f-rvj8-46c8
- https://nvd.nist.gov/vuln/detail/CVE-2026-50633
- https://lists.apache.org/thread/1czhgovkgzdkyp3t61wthn0foogh2grf
- http://www.openwall.com/lists/oss-security/2026/06/11/10
- https://access.redhat.com/security/cve/CVE-2026-50633
- https://bugzilla.redhat.com/show_bug.cgi?id=2488307
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-50633.json
- https://access.redhat.com/errata/RHSA-2026:37390