high7.1
CVE-2026-55514
vLLM denial of service via prompt embeds on M-RoPE models
Impact
vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | vllm | >= 0.12.0, < 0.24.0 | 0.24.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vllm | Vllm | from 0.12.0 before 0.24.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-33cg-gxv8-3p8g
- https://github.com/vllm-project/vllm/security/advisories/GHSA-33cg-gxv8-3p8g
- https://nvd.nist.gov/vuln/detail/CVE-2026-55514
- https://github.com/vllm-project/vllm/pull/45252
- https://github.com/vllm-project/vllm/commit/470229c37efaf69c86e8bc97482b0b1ff7551c65
- https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-2303.yaml
- https://github.com/vllm-project/vllm/releases/tag/v0.24.0