high7.3
CVE-2026-5842
A security vulnerability has been detected in decolua 9router up to 0.3.47.
Impact
A security vulnerability has been detected in decolua 9router up to 0.3.47. The impacted element is an unknown function of the file /api of the component Administrative API Endpoint. The manipulation leads to authorization bypass. The attack is possible to be carried out remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 0.3.75 is sufficient to resolve this issue. It is suggested to upgrade the affected component.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | 9router | < 0.3.75 | 0.3.75 |
Affected products
| Product | Affected versions |
|---|---|
| Decolua 9router | before 0.3.47. |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/decolua/9router/
- https://github.com/decolua/9router/issues/431
- https://github.com/decolua/9router/issues/431#issuecomment-4140163867
- https://github.com/decolua/9router/releases/tag/v0.3.75
- https://github.com/deepcat1337/Free_Api_Exploit/tree/main
- https://vuldb.com/submit/790003
- https://vuldb.com/vuln/356298
- https://vuldb.com/vuln/356298/cti
- https://github.com/advisories/GHSA-xrrh-p7f2-27vm
- https://nvd.nist.gov/vuln/detail/CVE-2026-5842
- https://github.com/decolua/9router