high8.7
CVE-2026-59153
Anki's local HTTP server does not sufficiently validate requests
Impact
Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | aqt | <= 25.9.2 | 25.9.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-869j-r97x-hx2g
- https://github.com/ankitects/anki/security/advisories/GHSA-869j-r97x-hx2g
- https://x.com/taviso/status/2051310678800253318
- https://nvd.nist.gov/vuln/detail/CVE-2026-59153
- https://github.com/ankitects/anki/commit/858e5689d0e4fd24f74856c7e8f245412694a219
- https://github.com/ankitects/anki/releases/tag/25.09.3