high7.5
CVE-2026-59898
Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation
Impact
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | io.netty:netty-codec-http | >= 4.2.0.Final, <= 4.2.15.Final | 4.2.16.Final |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Netty | Netty | before 4.1.136 from 4.2.0 before 4.2.16 |