NetSight
high7.3

CVE-2026-60080

Use After Free vulnerability in the Rust deserialization logic of Apache Fory.

Impact

Use After Free vulnerability in the Rust deserialization logic of Apache Fory. This issue affects Apache Fory from 0.13.0 through 1.3.0. A crafted Fory payload could cause undefined behavior, process crash, or potential memory disclosure. Users are recommended to upgrade to version 1.4.0, which fixes the issue.

Affected products

VendorProductAffected versions
ApacheFory
from 0.13.0 before 1.4.0

Weakness classification

References