high8.8
CVE-2026-65591
n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler.
Impact
n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | n8n | < 1.123.64 | 1.123.64 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| N8n | N8n | before 1.123.64 from 2.0.0 before 2.29.8 Version 2.30.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-pm35-fqvh-cq5g
- https://github.com/n8n-io/n8n/security/advisories/GHSA-pm35-fqvh-cq5g
- https://nvd.nist.gov/vuln/detail/CVE-2026-65591
- https://github.com/n8n-io/n8n/releases/tag/n8n@1.123.64
- https://github.com/n8n-io/n8n/releases/tag/n8n@2.29.8
- https://github.com/n8n-io/n8n/releases/tag/n8n@2.30.1
- https://www.vulncheck.com/advisories/n8n-before-sanitizer-bypass-remote-code-execution