NetSight
critical9.8

CVE-2026-65637

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.

Impact

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-coyote>= 11.0.20, < 11.0.2511.0.25
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 11.0.20, < 11.0.2511.0.25

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.115 before 9.0.121
from 10.1.53 before 10.1.58
from 11.0.20 before 11.0.25

Weakness classification

References