NetSight
medium5.9

CVE-2026-66053

Apache Thrift Python bindings have a Improper Validation of Certificate with Host Mismatch vulnerabilit

Impact

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603

Affected packages

EcosystemPackageAffectedFixed in
pipthrift< 0.24.00.24.0

Affected products

VendorProductAffected versions
ApacheThrift
before 0.24.0

Weakness classification

References