high7.5
CVE-2026-67590
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.
Impact
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Qpid Protonj2 | before 1.2.0 |