NetSight
critical9.1

CVE-2026-68525

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access …

Impact

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat>= 11.0.0-M1, < 11.0.2511.0.25
mavenorg.apache.tomcat:tomcat-catalina>= 11.0.0-M1, < 11.0.2511.0.25
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 11.0.0-M1, < 11.0.2511.0.25

Affected products

VendorProductAffected versions
ApacheTomcat
from 7.0.0 through 7.0.109
from 8.5.0 before 9.0.121
from 10.1.0 before 10.1.58
from 11.0.0 before 11.0.25

Weakness classification

References