high8.8
CVE-2026-68571
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin.
Impact
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. Special parameter in JDBC URL can lead to code injection. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache Kylin: From 4 | through 5.0.4. |
Versions were read from the advisory text. No structured product data has been published for this record yet.