NetSight
high7.5

CVE-2026-69152

brace-expansion: DoS via unbounded intermediate arrays, bypassing the CVE-2026-14257 mitigation

Impact

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.

Affected packages

EcosystemPackageAffectedFixed in
npmbrace-expansion< 1.1.181.1.18

Affected products

VendorProductAffected versions
JuliangruberBrace-Expansion
before 1.1.18
from 2.0.0 before 2.1.4
from 3.0.0 before 3.0.6
from 4.0.0 before 5.0.9

Weakness classification

References