critical9.8
CVE-2026-69263
Flowise: CVE-2025-8943 Patch Bypass: npm_config_yes bypasses MCP environment variable blocklist (Unauthenticated RCE)
Impact
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the mitigation for CVE-2025-8943 blocked -y and --yes flags on npx, but packages/components/nodes/tools/MCP/core.ts denied only PATH, LD_LIBRARY_PATH, DYLD_LIBRARY_PATH, and NODE_OPTIONS by exact environment-variable name. Because npm reads configuration from npm_config_* variables, setting npm_config_yes=true reproduced --yes behavior without using a blocked flag, causing npx to auto-install and execute the named package when a Custom MCP server launched. This issue is fixed in version 3.1.3.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | flowise | <= 3.1.2 | 3.1.3 |
| npm | flowise-components | <= 3.1.2 | 3.1.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Flowiseai | Flowise | before 3.1.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-xc48-889x-5qmw
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-xc48-889x-5qmw
- https://github.com/FlowiseAI/Flowise/pull/6471
- https://github.com/FlowiseAI/Flowise/commit/a4c4e4988cded15edf725e762560575b889ae351
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3