medium5.3
CVE-2026-73557
vLLM: Incomplete CVE-2025-62164 remediation can be bypassed by concurrent prompt parts
Impact
vLLM is an inference and serving engine for large language models. From 0.20.2rc0 until 0.26.0, safe_load_prompt_embeds in vllm/renderers/embed_utils.py uses torch.sparse.check_sparse_tensor_invariants, whose process-global save, enable, and restore state can be raced by concurrent prompt_embeds parts submitted to POST /v1/chat/completions through AsyncMultiModalItemTracker.resolve_items, asyncio.gather, and the default executor, allowing an invalid sparse tensor to reach tensor.to_dense despite the CVE-2025-62164 guard when enable_prompt_embeds is enabled. This issue is fixed in version 0.26.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | vllm | >= 0.21.0, < 0.26.0 | 0.26.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vllm | Vllm | from 0.21.0 before 0.26.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-pr7f-p5mw-fc87
- https://github.com/vllm-project/vllm/security/advisories/GHSA-pr7f-p5mw-fc87
- https://nvd.nist.gov/vuln/detail/CVE-2026-73557
- https://github.com/vllm-project/vllm/pull/48583
- https://github.com/vllm-project/vllm/commit/793cf79c89d4049124e756915468ac30318f2e50
- https://github.com/vllm-project/vllm/releases/tag/v0.26.0