CVE-2026-75913
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / c…
Impact
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rust | deepseek-tui | >= 0.3.27, <= 0.8.41 | none recorded |
| npm | deepseek-tui | >= 0.3.27, < 0.8.41 | 0.8.41 |
| rust | codewhale-tui | >= 0.8.41, < 0.8.64 | 0.8.64 |
| npm | codewhale | >= 0.8.41, < 0.8.64 | 0.8.64 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-7j5w-7r7x-9v27
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-7j5w-7r7x-9v27
- https://nvd.nist.gov/vuln/detail/CVE-2026-75913
- https://github.com/Hmbown/CodeWhale/commit/9a34b5034d29f05d1f28fa61b04719ca6a741020
- https://www.vulncheck.com/advisories/codewhale-before-argument-injection-via-git-show