critical9.4
CVE-2026-77405
RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser
Impact
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/rabbitmq/amqp091-go | < 1.13.0 | 1.13.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-33mj-cw25-m34h
- https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h
- https://nvd.nist.gov/vuln/detail/CVE-2026-77405
- https://github.com/rabbitmq/amqp091-go/pull/355
- https://github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e
- https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0