CVE-2026-77883
Exposure of sensitive information through data queries vulnerability in Apache Syncope.
Impact
Exposure of sensitive information through data queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access LinkedAccount's (if present) or Manager's (if defined) sensitive information, possibly including hashed credentials. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache Syncope: From 3.0.0-M0 | through 3.0.16 |
| From 4.0.0-M0 | through 4.0.7 | |
| From 4.1.0-M0 | through 4.1.2. |
Versions were read from the advisory text. No structured product data has been published for this record yet.