critical9.8
CVE-2026-78330
Incorrect privilege assignment vulnerability in Apache Syncope.
Impact
Incorrect privilege assignment vulnerability in Apache Syncope. When the configured JWKS settings for internal JWT authentication are disclosed (at least protocol and key), an attacker can obtain admin privileges after completing a successful authentication and obtaining a valid low-privileges JWT. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache Syncope: From 3.0.0-M0 | through 3.0.16 |
| From 4.0.0-M0 | through 4.0.7 | |
| From 4.1.0-M0 | through 4.1.2. |
Versions were read from the advisory text. No structured product data has been published for this record yet.