high7.3
CVE-2026-78654
A vulnerability has been found in cleverbrush framework and deep up to 4.4.0.
Impact
A vulnerability has been found in cleverbrush framework and deep up to 4.4.0. This impacts the function deepExtend of the file libs/deep/src/deepExtend.ts. The manipulation leads to improperly controlled modification of object prototype attributes. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 4.4.1 will fix this issue. The identifier of the patch is 810398c1308c500c3b8b6af380b5a89371389327. You should upgrade the affected component.
Affected products
| Product | Affected versions |
|---|---|
| Cleverbrush Framework And Deep | before 4.4.0. |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/cleverbrush/framework/
- https://github.com/cleverbrush/framework/commit/810398c1308c500c3b8b6af380b5a89371389327
- https://github.com/cleverbrush/framework/issues/213
- https://github.com/cleverbrush/framework/pull/215
- https://github.com/cleverbrush/framework/releases/tag/%40cleverbrush/async%404.4.1
- https://vuldb.com/cve/CVE-2026-78654
- https://vuldb.com/submit/886401
- https://vuldb.com/vuln/394866
- https://vuldb.com/vuln/394866/cti
- https://vuldb.com/submit/886401