NetSight
high7.5

CVE-2026-8161

multiparty@4.2.3 and lower versions are vulnerable to denial of service via uncaught exception.

Impact

multiparty@4.2.3 and lower versions are vulnerable to denial of service via uncaught exception. By sending a multipart/form-data request with a field name that collides with an inherited Object.prototype property such as __proto__, constructor, or toString, the parser invokes .push() on the inherited prototype value rather than an array, throwing a TypeError that propagates as an uncaught exception and crashes the process. Impact: any service accepting multipart uploads via multiparty is affected. Workarounds: none. Upgrade to multiparty@4.3.0 or higher.

Affected packages

EcosystemPackageAffectedFixed in
npmmultiparty<= 4.2.34.3.0

Affected products

VendorProductAffected versions
PillarjsMultiparty
before 4.3.0

Weakness classification

References