medium5.3
CVE-2026-82806
Exposure of data element to wrong session vulnerability in Apache APISIX.
Impact
Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache APISIX: From 2.3.0 | before 3.7.0. |
Versions were read from the advisory text. No structured product data has been published for this record yet.