critical9.1
CVE-2026-85228
An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remot…
Impact
An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remote unauthenticated actor to obtain information from adjacent process memory or cause a denial of service via a crafted tensor payload. To remediate this issue, users should upgrade to version 0.37.0 or above.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Amazon | Amazon Deep Java Library (DJL) From 0.13.0 | through 0.36.0 |
Versions were read from the advisory text. No structured product data has been published for this record yet.