medium6.3
CVE-2026-85241
A weakness has been identified in SpecterOps BloodHound up to 9.5.1.
Impact
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
Affected products
| Product | Affected versions |
|---|---|
| SpecterOps BloodHound | before 9.5.1. |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/SpecterOps/BloodHound/
- https://github.com/SpecterOps/BloodHound/commit/39d1276a63e95a7713f954dea632a19651d9cebb
- https://github.com/SpecterOps/BloodHound/releases/tag/v9.6.0-rc1
- https://vuldb.com/cve/CVE-2026-85241
- https://vuldb.com/submit/894488
- https://vuldb.com/vuln/398471
- https://vuldb.com/vuln/398471/cti