critical9.1
CVE-2026-85499
Improper Authorization vulnerability in Apache SkyWalking BanyanDB.
Impact
Improper Authorization vulnerability in Apache SkyWalking BanyanDB. The Canopy includes incomplete proof-of-concept role and monitoring-proxy functionality. Under a non-default configuration with a readonly Canopy user and a reachable monitoring target, that user can send non-read requests through the monitoring proxy. This issue affects Apache SkyWalking BanyanDB: from 0.11.0 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache SkyWalking BanyanDB: From 0.11.0 | before 0.11.1. |
Versions were read from the advisory text. No structured product data has been published for this record yet.