medium4.3
CVE-2026-86289
A vulnerability was found in Ollama up to 0.31.1.
Impact
A vulnerability was found in Ollama up to 0.31.1. This issue affects the function readGGUFV1String of the file fs/ggml/gguf.go of the component GGUF Decoder. Performing a manipulation results in integer overflow. The attack is possible to be carried out remotely. The exploit has been made public and could be used. Upgrading to version 0.31.2-rc1 is capable of addressing this issue. The patch is named 67b6a1c2d45321e0cb3c04a18073f9818de7724b. It is recommended to upgrade the affected component.
Affected products
| Product | Affected versions |
|---|---|
| Ollama | before 0.31.1. |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/ollama/ollama/
- https://github.com/ollama/ollama/commit/67b6a1c2d45321e0cb3c04a18073f9818de7724b
- https://github.com/ollama/ollama/issues/17033
- https://github.com/ollama/ollama/pull/17062
- https://github.com/ollama/ollama/releases/tag/v0.31.2-rc1
- https://vuldb.com/cve/CVE-2026-86289
- https://vuldb.com/submit/906136
- https://vuldb.com/vuln/399448
- https://vuldb.com/vuln/399448/cti