medium5.4
CVE-2026-86589
Incorrect implementation of authentication algorithm vulnerability in Apache Answer.
Impact
Incorrect implementation of authentication algorithm vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.2. A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked. Users are recommended to upgrade to version 2.0.3, which fixes the issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache Answer | through 2.0.2. |
Versions were read from the advisory text. No structured product data has been published for this record yet.