critical9.1
CVE-2026-89238
WSS4J EncryptedHeader child confusion could promote an attacker-controlled plaintext element as the decrypted header, leading to incorrect confidentiality cove…
Impact
WSS4J EncryptedHeader child confusion could promote an attacker-controlled plaintext element as the decrypted header, leading to incorrect confidentiality coverage and possible policy bypass. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Wss4j | before 2.4.4 from 3.0.0 before 3.0.6 from 4.0.0 before 4.0.2 |