NetSight
medium4.3

CVE-2026-93960

A vulnerability was identified in Pixelfed up to 0.12.11.

Impact

A vulnerability was identified in Pixelfed up to 0.12.11. Impacted is the function instancePeers of the file app/Http/Controllers/Api/ApiV1Controller.php of the component OAuth Scope Handler. Such manipulation of the argument ID leads to missing authentication. The attack may be performed from remote. The exploit is publicly available and might be used. Upgrading to version 0.12.10 is recommended to address this issue. The name of the patch is 68dca5097305fa0065d029587b2233524636025a. Upgrading the affected component is advised.

Affected products

ProductAffected versions
Pixelfed
before 0.12.11.

Versions were read from the advisory text. No structured product data has been published for this record yet.

Weakness classification

References