medium5.1
CVE-2026-94276
Improper Authentication vulnerability in Apache APISIX.
Impact
Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apache APISIX: From 3.12.0 | through 3.18.0. |
Versions were read from the advisory text. No structured product data has been published for this record yet.